Technical Support

This used to be a technical support forum. But now it's just an archive of questions and answers. Mostly questions. We were always too lazy to answer.


FROM - AndyMeriden, CT
TOPIC - Blank pages??
01/18/99 15:24:10 - MESSAGE #348

Looks like the cgi wants to work but comes up with a blank page after you try to submit a post.

I looked at the permissions and even split the files so cgi's are seperte.

Help!!

FROM - Steve Luxembourg
TOPIC - Help
01/17/99 18:57:28 - MESSAGE #333

This script seems to be right cool, nevertheless, i can't get it working :( I always get this error message
Method Not Allowed
The requested method POST is not allowed for the URL /~twiti/cgi-bin/fruity_sub.pl.
Aren't my path correct or what could be the problem ?
Please help !

FROM - simboner
TOPIC - question
01/17/99 15:48:50 - MESSAGE #328

How do i view the IP address of a post?

FROM - cctest
TOPIC - test
01/17/99 10:01:14 - MESSAGE #322

test

FROM - Nick Germany
TOPIC - No message posts
01/14/99 04:02:57 - MESSAGE #235

Hi,
I got Fruitbbs running and everything's great except that when you fill in messages only the name and email address proof shows up - not the message. Interesting.

Anyone have any suggestions?

Thanks!

FROM - rbcpAlton, IL - 208.235.31.31
TOPIC - FruitBBS 3.01
01/13/99 15:22:53 - MESSAGE #219

If anyone is interested in upgrading - I released the official new version of FruitBBS the other day.

Click here to get it.
TOPIC - Where to start?
DATE - 01/03/99 00:00:09
FROM - Josh K. Oregon

Ok, I'm a big AOL dummy! I cheated on my web page by getting Claris Home Page 3.0, and I do not know HTML. I want a message board on my web site.
The Address is:

http://www.geocities.com/Colosseum/Bench/5326

I want the message board page on:

http://www.geocities.com/Colosseum/Bench/5326/boards.html

So I would ask for all the help possible.
Thanks in advance,
Josh

"The Devil Times"
TOPIC - It works fine, Here are the tricks
DATE - 12/20/98 20:10:35
FROM - Joe USA - 38.30.200.20

In the fruity_sub.pl the paths can be a little tricky.

$rootpath = should be the complete server path of you directory that you are going to place the htm files, not the cgi.
$rooturl = this is your URL that coorespondes with the above rootpath.
$cgiurl = The URL where your cgi-bin is (if your placing the script in the base of the cgi-bin directory).
Add the bad word patch from here (http://megaserv.msctm.net.my/cyberria/fruitbbs.html)

In the admin perl file, the following applies

$adminurl = the URL where you are placing the admin script (generally the cgi-bin dir).
$rootpath = This is the server path to your root directory. Not to the script or cgi-bin dirs.
$rooturl = Is the URL that coorespondes with the rootpath above (www.yourname.com/)
$cgiurl = The URL for your cgi-bin dir

Now upload the .pl or .cgi files to your gi-bin dir or the path you set in the scripts.
upload the remainder files to the path (not cgi-bin) you setup in the scripts.
Change the .pl or .cgi to 755 and the rest to 777.
Dont forget to make the badword.htm file and upload it to the same dir as the other htm files and chmod to 777.

Create the noaccess.txt fflog.htm and upload to the same dir as the other htm files. chmod to 777. It should work.

For the admin script to work. you must put the compete path of the file which contains the message to be deleted.
(i.e. if your server path is /root/myname/htdocs/scripts/fruit/sub1.htm, and your URL is www.yourname.com/scripts/fruit/sub1.htm then the admin file path would be /scripts/fruit/sub1.htm )

Good luck

TOPIC - Help
DATE - 12/18/98 19:50:45
FROM - Earl CA - 207.217.233.13

When I run the the fruity_sub.pl script , I get the error message :
Undefined subroutine &main::error called at fruity-sub.pl line 82.

Any Ideas anyone.

TOPIC - 500-Internal Server Error
DATE - 12/11/98 22:28:40
FROM - Deidre Atlanta, GA



HTTP 500 - Internal server error
Internet Explorer

I always get this and I've followed everything on this list that I could. The thing I wonder about is that Date code. What is that? Is there another .pl file for that date?

Otherwise Everything is like everyone else has said to put it, but nothing has worked yet. So far this is the easiest one I have worked with, I just need to know how to stop that 500 Internal Error thingy.

TOPIC - Whoops
DATE - 11/08/98 00:21:06
FROM - Jason NE

Sorry....The help page is at
http://garretts.hypermart.net/bbshelp.htm


TOPIC - Help page
DATE - 11/08/98 00:18:55
FROM - Jason NE

Go to http://garretts.hypermart.net/bbs.htm
for help.

Garrett's: The Coolest Place on the Net!

TOPIC - badword
DATE - 11/05/98 17:17:25
FROM - Riff - No domain available

I am having the same problem as Carlos...I finally got the script running and now when i try to post it won't accept anything I type in....eeeeerrrrg


TOPIC -
DATE - 11/05/98 15:15:47
FROM - Carlos Brasil

"SORRY, We're sorry, but something you wrote offended us and we just can't post your message unless you decide to make a few changes in your wording. Click the back button and try it again, buck-o."

Why do I get this message all the time,when trying to post?

I checked the code.. And there actually is some mumble about "badwordlist", but what's the problem?


TOPIC - Ok everything on a row
DATE - 11/05/98 12:43:18
FROM - Bluestrike belgium

my administration .pl file works great.
Everything else works.

Exept the post a message button.
When I klik on it I get this message:
You silly fruity moron
You didn't write anything in the comments field. What is the point of a message if you don't write a message. Retard. Back up and try again or just return to the discussion board.

What did I do wrong?
Litte type error somewhere?
Chmodded wrong?
...



TOPIC - Please help!!!
DATE - 11/05/98 00:05:24
FROM - Kris Cleveland, OH - No domain available

OK, I've decided there's something wrong with the entire script. Taking the bad word code out should make it work, and it doesn't. PLEASE, SOMEONE EMAIL ME A WORKING SCRIPT!!!!!!
thank you


TOPIC - Please help1!!
DATE - 11/05/98 00:05:17
FROM - Kris Cleveland, OH - No domain available

OK, I've decided there's something wrong with the entire script. Taking the bad word code out should make it work, and it doesn't. PLEASE, SOMEONE EMAIL ME A WORKING SCRIPT!!!!!!
thank you


TOPIC - Found a part of previoes post
DATE - 11/04/98 14:08:55
FROM - Blue again Belgium

I found out what i have to fill in at
$rootpath="data1/hypermart.net/loginname/"

can that be right?

Ok one mre problem anymore, Why don't I get the screen where I can enter my message like the one I am facing right now?

Is there something in the *.pl or in one of the *.htm
files wrong?

mutch thanks in advanced.


TOPIC - help I almost have it to work
DATE - 11/04/98 12:49:52
FROM - Bluestrike Belgium

Hello, When I klik on the post message button I get a
message called:
You fruity moron ......
it say's i didn't add tekst.
but I didn't had the window to enter the tekst.

Myabe it has to do with this line out the fruity.sub.pl

$rootpath = "/html/virtual/FruitWare/"; # include trailing slash

I really don't know what I have to do here.

if somybody can help me solve those problems, then it works.

thanks, very very mutch.

Cool message board eh.


TOPIC - Halp!
DATE - 11/04/98 01:39:40
FROM - Kris Cleveland - No domain available

Could someone email me the correct fruity_sub.pl because I'm going bonkers with this thing. It doesn't make any sense. I erase the code for the bad word thing and it gives me an error, but looking at the script it doesn't seem to tie into anything else. As a test, I erased the no access part of the script and it worked fine (well, if you consider returning the bad word message as working). What gives?


TOPIC -
DATE - 11/03/98 20:59:58
FROM - L.D.

to RCBP
One of the big problems With the script is when you allow html. Sometimes the font and center tags take over the whole page, color, font size etc. even when all the tags are closed out. I am with you on disliking the other click on thread style board. I think this can become a great board so get to work. pleeeaaaasssse.


TOPIC - Thing still don't work
DATE - 11/03/98 01:29:07
FROM - Kris Cleveland, Ohio - No domain available

Man, i've tried everything posted on here and I still can't get past the bad word thing. I've addes a badword.htm file, I deleted the badword code, I uncommented it, I replaced it with the "right" code, and nothing. Has anyone else been able to fix it?



TOPIC - fruity_sub.pl badwords fixed
DATE - 10/29/98 04:38:20
FROM - SiFu Malaysia

I manage to fixed the problem with the help from you guys....
if you want to see how I do it... go to the link below:

http://megaserv.msctm.net.my/cyberria/fruitbbs.html

good luck!...and thanx for whoever post the fixed in here :)

fruity_sub.pl fixed

TOPIC - fruitbbs & cgi-bin
DATE - 10/27/98 01:02:27
FROM - earl Calif. - No domain available

My providers server is a Unix machin. I have read only access to his cgi-bin. For my own cgi files I have created a directory called /cgibin/ for my use. Can I use the fruitware BBS system and chat system on my website?

Thanks Earl


TOPIC - Wow...
DATE - 10/27/98 00:47:12
FROM - rbcp Alton, Illinois - No domain available

Hi, I'm the guy who created the FruitWare BBS. It's just something I decided to do because I didn't like many of the other BBS programs out there and I released it on a few script archive pages one day when I was bored. All I can say is wow! I can't believe so many people are using it now. I haven't even visited this tech support sub in like six months - I happened across it by mistake and find all these people having problems, asking questions and best of all helping each other and setting up help pages to solve my faulty scripting.

Thanks goes to everyone who's using the script, especially those who are hanging out in here and helping out the other users. I admit that I slapped the whole script together in a very short time, yanking parts out of other scripts I liked and leaving a bunch of junk in there that's not useful and wastes space. Also, when I released the fixed version 2.01, I left the links to phonelosers.org in there which caused even more problems.

Since it appears that many people are using the script and sticking with it despite the problems, I'm going to try and get a version 2.02 out as soon as I can which will have the script cleaned up a little bit and include ALL of the neccessary files it needs to run. This won't mean much to those who are already running it, but it will help with getting it set up easier for the new users.

What I need are suggestions. Obviously if people are using the script, I'm obligated to release a version 3.x one of these days. So tell me what you'd like to see in version 3.x and I'll try my best to work it in. (Just post your suggestions in here) And tell me what you hate about the current script and where improvements could be made. Apologies go out to everyone who had problems installing the sucker and thanks for sticking with it after you finally got it to work.

Alex

TOPIC - Need help??????
DATE - 10/24/98 15:57:18
FROM - Jason Garrett NE

Anyone who needs help configuring fruit BBS should go to my help page.
It is located at
http://garretts.hypermart.net/bbshelp.htm

Garrett's: The Coolest Place on the Net

TOPIC - fruitchat problem
DATE - 10/23/98 16:42:55
FROM - Juergen Rall Germany - No domain available

hi,

I was playing no for about 2 days to set up a chat room, but still something goes wrong. First I磎 not shure if I've update the cgi correctly. So my directory structure looks like following:

/
/cgi-bin
/cgi-bin/fruit_chat.pl

/bin/date

/chat
/chat/chat.htm
/chat/chat_info.htm
/chat/chat_input.htm
/chat/chatlog.htm
/chat/chatpage.htm

Thats what I changed inside fruit_chat.pl:

$chatpage = "/chat/chatpage.htm";
$chatpageurl = http://www.sybera.de/chat/chatpage.htm";
$chatcgiurl = "http://www.sybera.de/cgi-bin/fruit_chat.pl";
$chatinfo = "http://www.sybera.de/chat/chat_info.htm";
$chatinput = http://www.sybera.de/chat/chat_input.htm";
$chatlog = "/chat/chatlog.htm";
$date_command = "/bin/date";

What happens:

script seems running correctly, but inside the main chat window only 25 equal lines appear (and nothing else):

[rbcp] fruitchat v. ...
[rbcp] fruitchat v. ...
[rbcp] fruitchat v. ...
...

If you've any idea to solve this problem, please write me to [email protected]

best regards,

juergen rall, sybera, germany


TOPIC - Read first... Then ask...
DATE - 10/21/98 19:20:17
FROM - WowTIP Sweden - No domain available

Yeah, I know, sorry...


TOPIC - Sorry, yeah!
DATE - 10/21/98 19:12:00
FROM - WowTIP Sweden - No domain available

"SORRY, We're sorry, but something you wrote offended us and we just can't post your message unless you decide to make a few changes in your wording. Click the back button and try it again, buck-o."

Why do I get this message all the time,when trying to post?

I checked the code.. And there actually is some mumble about "badwordlist", but what's the problem?


TOPIC - YES!!!!
DATE - 10/12/98 23:20:18
FROM - Jason Garrett NE

Well I finally got it to work. Thanks everyone. If anyone needs help just e-mail me and I might be able to help.

Garrett's

TOPIC - 敢死队风格
DATE - 10/09/98 22:55:14
FROM - 按时的法 感到风格 - No domain available

规范化稻谷用途


TOPIC - 敢死队风格
DATE - 10/09/98 22:55:12
FROM - 按时的法 感到风格 - No domain available

规范化稻谷用途


TOPIC - fg
DATE - 10/09/98 22:51:17
FROM - fff china

asdf


TOPIC -
DATE - 10/09/98 16:13:27
FROM - qqq

qqq


TOPIC - 500 Server Error
DATE - 10/08/98 22:09:14
FROM - Jason NE

I have tried repeatedly to get this script to work. I have created the fflog.htm file the noaccess.txt file, I have set all permissions and as far as I can tell everything is right. Would someone be interested in installing the script for me???
Thanks.

Garrett's

TOPIC - help
DATE - 09/29/98 20:29:10
FROM - Jess Hawaii

Undefined subroutine &main::error called at /usr/local/etc/httpd/htdocs/mauisfreepress/cgi-bin/fruity_sub.pl line 82.
[Tue Sep 29 20:26:45 1998] access to /usr/local/etc/httpd/htdocs/mauisfreepress/cgi-bin/fruity_sub.pl failed for 1cust7.tnt1.wailuku.hi.gt.uu.net, reason: Premature end of script headers


TOPIC -
DATE - 09/17/98 00:45:17
FROM - L.D.

I have two copys of the board up and running.I had to make so many changes i can not rember them all. The bad words i did not need so i cut it out. the script will not work right as it is. The part i need to work is the ban ips has anyone got this part to work. I had to cut this part out also because sometimes it would fly off and tell people they were spamers even though no ip was listed in the ban list. I think the person who wrote this script has a funny sense of humor. I ran into all the problems posted on this board and more just when you think you have it all fixed you are hit with one more problem to fix. PS I love the board


TOPIC - won't write to sub1.htm
DATE - 09/17/98 00:14:06
FROM - Dan

The .pl script will execute, and bring up the post message fields, but gives an 'internal error' and won't write to either the log file or the sub1.htm

I suspect a pathing problem, but here is the structure:

$rootpath = "fruit/";
$rooturl = "http://www.mysite.com/";
$cgiurl = "http://www.mysite.com/cgi-bin/fruitnews.pl";
$noaccess = "noaccess.txt";
$sublog = "sublog.htm";

The sub1.htm file is located in www.mysite.com/fruit

Any ideas?



TOPIC - i need help
DATE - 09/13/98 04:27:54
FROM - ZerO asia - No domain available

my chatline no functioning
wat happen?
nothing written on it :(

zero page

TOPIC - chat program
DATE - 09/05/98 14:37:08
FROM - Lisa

For what it's worth, if you downloaded the script for the chat program thinking that what you saw was what you'd get, think again. The demo chat is a java program, the download is straight cgi. It's not bad.. but they placed a default of 25 lines in the code. Removing them from the variables isn't hard, but the script then becomes problematic as to getting text to the screen.. errors in where the script is searching, etc. somewhere a hidden variable sends the browser to phonelosers.org rather than your own server. Same problem with BBS but it's easier to find in bbs. When setting bbs variables, make sure any redirect is to your server and not phonelosers.org - I gave up trying to get admin to work and just manually edit htm sub files to delete messages. BE VERY CAREFUL when searching for scripts. Last week I managed to download a virus from one of these sites while looking for chat/bbs programs. My antiviral found it, but not before I updated sig files. Update your sig files so you don't run into trouble!


TOPIC - Important
DATE - 09/04/98 19:03:49
FROM - Guillaume USA

I have a request BUT private, could you send me your email ? [email protected]

THANX


TOPIC - Deleting Messages
DATE - 09/04/98 10:14:51
FROM - Sunny Canada

Ok, I finally managed to delete a few messages. Others I can't delete. Why? No idea! It says Message Deleted but when I check it's still there. That doesn't make any sense! Why can I delete some messages but not others?
Any ideas?


TOPIC - Help
DATE - 09/04/98 00:18:28
FROM - Scott CAN

Thanks for that info Lisa, but that doesn't seem to be the problem. I am lost as to what is the problem. I have done everything correct to my knowledge...that is why i thought there were other things people had trouble with.


TOPIC - The Answer to 500 Internal Server Error
DATE - 09/03/98 17:53:30
FROM - Lisa

Okay, here it is again - you must create noaccess.txt and fflog.htm and upload them to your server - then you must chmod 777 both of em. There is an error in the instructions. There is no fruity_bbs.pl - the actual file is fruity_sub.pl (or cgi if you rename it). That's it k? Now if anybody knows a fix for the Message Deleted deal (they aren't really deleted that way) I'd love to hear it. The board works awesome, especially when you change the graphics, background, etc.



TOPIC - Internal Server Error - Files You Must Create
DATE - 09/03/98 17:50:49
FROM - Lisa

Why don't you guys just scroll down? The answer is right there, Tommy Lee posted it. You have to create two files and put em in the directory - then it will run just fine. Now getting messages to delete without actually having to edit the HTML - that's a whole nother story.


TOPIC - Really need help
DATE - 09/03/98 15:00:55
FROM - Scott CAN - No domain available

Ok, i think its something with the fruity_sub.pl file, cause i have tried everything to get it to work, and always internal errors. I really like the look of this board, but I am tired of boards giving half ass instructions...and this guy didnt even update the manual...I know its free, but hey the candy has been waved in my face...someone help me out before i give up on this msg board thing


TOPIC - I need Help
DATE - 09/03/98 14:31:22
FROM - Edwin Martinez Guatemala - No domain available

I try to mount this script in my server but nothing happens, the server showme an error "The server encountered an internal error or misconfiguration and was unable to complete your request." and I do all (permissions, rootpath, etc) but nothing happend, Please If somebody can help I will thank up all the time.


TOPIC - HELP
DATE - 09/03/98 13:20:29
FROM - Scott Can

Ok, do you need fruity_bbs.pl, cause that was not included in my zip file.

Also, I find I am having problems with internal errors, I kinda changed the html pages for my own format, but pretty much kept the same lines, so I don't understand why I cant post...

if someone is really good at this, please email me


TOPIC -
DATE - 09/01/98 18:52:07
FROM - tao again

Okay, three comments on what I just posted:

1 unless you actually care about people posting "bad words", you might as well only delete the bit I indicated, and forget about replacing it with my code.

2 because the "webmaster?" has disabled html on this board, two lines of code (which were actually identical) didn't come out right: where it says:
@FILE = ;

in both cases, it should be
@FILE = <FILE>;

3 the last line of code (ignoring the brackets) down below, which reads
&bad_word($i);

should just be
&bad_word;

the $i thing was just me messing around.


TOPIC - Badwords
DATE - 09/01/98 18:36:21
FROM - Tao , Edinburgh

Okay.

The bad words thing seems to be something the original author thought about, but never completed.

start by setting a $badwords variable at the top (of the fruity_sub.pl file), where all the other variables are set (just like all the other files eg fflog.htm).

now create this file (call it what you will),
do
chmod 755 filemane
on it (replacing "filename" with the name of your file),

now open fruity_sub.pl, and replace:



$badbad = $FORM{'comments'};
open(FILE,"$rootpath$badwords") || &error('open->random_file',$badwords);
@FILE = ;
close(FILE);
$badwordlist = join('',@FILE);
if ( $badbad =~ $badwordlist ) {
&bad_word;
}



with

$badbad = $FORM{'comments'};
open(FILE,"$rootpath$badwords");

@FILE = ;
close(FILE);

foreach $i (@FILE) {
chomp($i);
if ( $badbad =~ $i ) {
&bad_word($i);
}
}



TOPIC - Problem Solved - Thanks Tommy Lee!
DATE - 09/01/98 15:41:14
FROM - Lisa

Well, I read down further on this BBS and found the answer - thanks Tommy Lee - you were right on! The answer is create the noaccess.txt and fflog.htm files then chmod777 em - works fine for now - hope I don't encounter more :)


TOPIC - Swap info
DATE - 09/01/98 15:00:03
FROM - Lisa

To get around the sorry you offended message (or badworst list message, etc), edit the fruity_sub.pl (or cgi) to comment out the section that applies - comment out means in front of the variable you place /* and at the end you place */ - this tells the script to ignore that portion.

Now.. if anyone can tell me how to get around the 500 error I'd be grateful. As near as I can see, all variables are correct - path to cgi remains home/ftp/fid2/1118/yourname/FruitWare (yourname is bogus) - I know that's right, my postcard and chat scripts run with the same path-to-cgi.. the actual path to perl at top is !usr/bin/perl or !usr/local/bin/perl doesn't seem to matter how I configure that portion, whether or not it's local or add a 5 to the back of it, script won't run.

Any suggestions that work?

Thanks


TOPIC - Re: Bad Language Error
DATE - 09/01/98 04:19:20
FROM - Miska from the Hidden City - No domain available

Ok, now this is a bit strange. I got the script running, but when I went to do a test post I received the 'Sorry ~ something you wrote offended blah blah blah error. I didn't say anything in my post but 'test post'! Can anyone tell me what is going on with this and how to not get this error?

Thanx,
Miska


TOPIC - hello me again
DATE - 08/29/98 18:52:37
FROM - Bluestrike Belgium

Wel I finally found out my server does not support chi for security reasons so maybe that explains my error message I got.

Well I found a new server but I am building a new homepage first.


TOPIC - Administration
DATE - 08/28/98 10:55:11
FROM - Sunny Canada

Hi,

I'm trying to delete old messages using the administration script. The first time it worked fine and the message was deleted. Now I tried it again with another message but it doesn't work anymore. It says message deleted but it deletes nothing.
Do messages expire after a while?


TOPIC -
DATE - 08/26/98 20:36:11
FROM - tao

Sorry, I meant reload, not refresh.


TOPIC - refresh?
DATE - 08/26/98 20:35:21
FROM - Tao UK

It's slightly irritating that after having posted your message and returned to the "discussion board", you still have to press refresh...
Can anything be done to force Netscape/Internet Explorer to ignore the cache?


TOPIC - method not allowed
DATE - 08/23/98 14:23:23
FROM - Kenny oregon - No domain available

I am getting the same error message as blue from Belgium
"The requested method POST is not allowed for the URL"


TOPIC - error
DATE - 08/19/98 15:03:29
FROM - Blue Belgium

I get this error when I press post a message:

Method Not Allowed
The requested method POST is not allowed for the URL /bs302651/cgi-bin/fruity_sub.pl.

can somebody help me?

E-mail me :-)


TOPIC - to-codefrees
DATE - 08/19/98 13:32:47
FROM - CHALIES tw

About the error 500 ..
You must set path for CGI.
As /usr/bin/perl or another path ....
You could use Telnet to find the right path for cgi.
Always type "whereis perl" that be show you perl-path.

腳供瓣悔呼悔

TOPIC - CGI-BIN
DATE - 08/19/98 13:24:20
FROM - CHALIES TW

ABOUT THE CGI-BIN THAT YOU MUST CONTECT YOUR SERVERS !!


TOPIC -
DATE - 08/17/98 18:04:35
FROM - Bruce mace

I uploaded ir into my personal ftp. I have a question. Where is the Cgi-bin?


TOPIC - 500 & config
DATE - 08/16/98 22:18:24
FROM - codefreez - WaveTech.net

Ok, I've been playing with this two days, and I can't get it to work. I am consistantly getting Error 500. Tell me if I havn't done anything, or mention something to try:

1. edited the .pl and .htm files per my server setup
2. saved the file in "unix" text format (with bbedit)
3. ftp'd as text, not binary
4. changed permissions, 755 for scripts, 777 for html and logs
5. renamed perl scripts .cgi (as my host says it "needs" to be) and replaced the file name in the html
and scripts.
6. Switched /usr/bin/perl to /usr/local/bin/perl5 ("which perl5" gives me that location)
7. double checked many fucking times.

The script runs, and when I leave the entry box blank, or I just run "perl fruity_sub.cgi" I get the error message from fruitware that you would expect, but when the entry boxes have stuff in them, I get the error 500. Ughh..this is really pissing me off--and I have perl experience.


TOPIC - internal server error
DATE - 08/15/98 02:18:42
FROM - phkngruven joisey - psi.net

i set up the dummy files and edited the scripts .. i had to tinker with the date command until it worked, at first it told me there were invalid parameters (when i had it listed as /usr/cgi-bin/date it wouldn't work, when i just left date it did) .. now when i try running the perl script from the shell it just hangs there and when i run it through lynx or ie i get an internal server error. any explaination? i mean, so far, from what i've seen, this is a great program ... i just wish i could get it working.


TOPIC - BBS
DATE - 08/14/98 23:54:57
FROM - Nicole - mci.net

I'm sure anyone who's done the BBS successfuly wouldn't be in this section but its worth a shot:

My host uses perl 5.002 or better and I don't know if it makes a difference or not. The best I have done with this script is when the post a message button is clicked it begins to download (asks if you want to save to disk or to open). I kept the subs as .pl and changed the first lines to #!/usr/local/bin/perl5.003
#/zyview/vscripts 775 (I found this in the script of someone elses cgi at my host). The more I get into this the more severe my headache. I thought this was so simple "even an AOLer can do it".

If anyone can help out it would be appreciated GREATLY. I'm sure other boards are easier but I dont like threads.


TOPIC - Fruit Chat
DATE - 08/12/98 03:26:07
FROM - julip Indiana

Hi,everytime i try to post a message,i get nothing,i looked in my log file,and my logs where there,but i cant post messages on the chat line???I dont know if im setting the paths right,but i started them with http:// if you could help pleaseeeee do...

Chat

TOPIC - badword error
DATE - 08/09/98 15:52:50
FROM - Dave My mom

I have fruity up and running and when you go to place a post it always says: We're sorry, but something you wrote offended us and we just can't post your message unless you decide to make a few changes in your wording. Click the back button and try it again, buck-o. ...... There is no documentation on the bad word list, soI did not upload any badword files.???
I could really care less about this feature of the BBS, is there a way to disable it..... I do not know what the problem is and I am lossing patients. Anyone else have this problem?

Email me if you know how to get around this bug


TOPIC - CGI-BIN
DATE - 08/07/98 18:18:12
FROM - KewlKatN84 California

How do you get the CGI-BIN???


TOPIC - How to start
DATE - 08/07/98 18:17:25
FROM - KewlKatn84 California - psi.net

HOw do you get it to start? do you just suddenly upload it? then what?


TOPIC - BadWords
DATE - 07/28/98 12:15:05
FROM - CONDOR USA

Hi,

The bad word list function didn't seem to work so I modified the script to enable it. Problem is that now it only works if you only type bad words....When badwords are used in a sentence mixed in with other words, it posts the message anyway! I've tried 1 line/word as well as a long line of words in the txt file but it didtn't make a difference...Perhaps a delimiter would work?

Does anybody know how to make it so that the badwords will be identified when mixed in with other accepted words?

I'll follow up on this to see if anybody has a response!

BTW: In order for the Admin functions to work, the sub htm files must be set to CH 777 since these files need to be read and written to by the script.

Thanx in advance

CONDOR


TOPIC - Expiring Messages
DATE - 07/28/98 05:22:14
FROM - Zeke2 San Francisco - bigger.net

Another question: Do these messages automatically expire after a set number of days? Can I set up FruitBBS to expire messages more than 30 days old? Thanks in advance.


TOPIC - Passwords?
DATE - 07/28/98 05:11:56
FROM - Zeke2 San Francisco - bigger.net

Thanks to the author(s) for creating such a nifty web BBS! I have this question: Can I make this BBS require a password before logging on? I want each user to have his or her own special password. Perhaps there is a module that I can plug into this script? (I already have a good password gate that can log you onto whatever page I have set up...but anyone can still log onto the page in question, if he knows its actual URL.)


TOPIC - All those errors
DATE - 07/16/98 22:26:44
FROM - Tommy Lee Korea - No domain available

I was pulling my hair out but finally I got this thing working. I'm sure this will help many of you that I see have posted here.
YOU must create 2 files that are required but do not come with the zip file:
noaccess.txt & fflog.htm
just create two empty text files and stick them in the dir.
Also,
chmod 777 *.htm
chmod 777 *.txt
also,
verify the date command works, just go to the fruity dir and type:
/bin/date
if you get a date, it works!
also I had to change my first line to:
#!/usr/bin/perl5
finally on some servers you might rename the file:
fruity_sub.cgi
make sure you remember to
chmod 755 fruity_sub.cgi
Later,
Tommy Lee

Incubus Technologies

TOPIC - Premature end-of-script headers?
DATE - 07/14/98 13:12:54
FROM - Sean - ibm.net

Every time I try to post a message I get a "[500] Error: Internal Server Error" message. When I view the error log, the latest error is :

[Tue Jul 14 12:07:46 1998] access to /data1/hypermart.net/epiclie/cgi-bin/fruity_sub.pl failed for 32.100.232.218, reason: Premature end of script headers

Does anybody know what that means? (I know absolutely nothing about PERL)

Sean

Here

TOPIC - Internal Errors
DATE - 07/12/98 23:44:31
FROM - Erin - dialsprint.net

Every time I try to set the permissions, it keeps saying something about remote hosts don't accept permission changes.


TOPIC - Server Path
DATE - 07/08/98 19:52:44
FROM - Jamie Tucson - gci-net.com

All seem to work ok up until I post a message. I am on a NT Server. I have put in the path, but I get a 404 error. I have even tried useing the drive letter of the ftp server in the path, but no luck.


TOPIC - fruity_bbs.pl
DATE - 07/02/98 12:50:14
FROM - Mark N.M - zianet.com

fruity_bbs.pl not included in the zip file


TOPIC - register users
DATE - 06/27/98 07:45:41
FROM - twin01 germany - swol.de

Hi there
How can I make that suers must register with their Nickname, Passwort and E-Mail address first, before they can enter the chat?
Please E-Mail me

yours
[email protected]


TOPIC - OK - Another Question
DATE - 06/26/98 03:54:36
FROM - John B

Sorry about the first question. I just forgot to set the paths in the html files. But now when I click Post Message for the first time (there are no existing messages), it tells me I'm a silly guy.


TOPIC - Can't get it to work
DATE - 06/26/98 02:49:01
FROM - John B

Hello,
Forgive my lack of script knowledge, but I can't get this thing to work. Could it be because there is no "date command" in my cgi-bin? Except for the files I put in there for this, the cgi-bin is empty.

I'm also confused about setting permissions. I typed "chmod 755 *" in the cgi-bin and "chmod 777 *" in the FruitWare directory.

Thanks,

John


TOPIC - BBS Problems
DATE - 06/22/98 08:24:06
FROM - Marc Lopez Barcelona

Hello!

We have a Novell Webserver and my question is:

Can run properly your Web-based BBS under Novell software?
I have some problems (Text error says me: "Document contains no data")
I think that is due to directory configuration but it seems to be correct.

Thanks in advance and congrat's for your program


GreenBit, Enginyers en Software
http://www.greenbit.es

Marc Lopez

[email protected]


TOPIC - hello...
DATE - 06/21/98 22:23:40
FROM - rbcp 618 - midwest.net

We wiped out the technical support BBS some time ago and I was just too lazy to set it up again. So here it is again! Maybe this time people will actually use it. Feel free to ask any questions you may have about any of our three cgi scripts. You can also suggest some ideas for future versions of scripts which we will consider when updating..,

ME

Our Sponsors